www.acmicpc.net/problem/1780

 

1780번: 종이의 개수

N×N크기의 행렬로 표현되는 종이가 있다. 종이의 각 칸에는 -1, 0, 1의 세 값 중 하나가 저장되어 있다. 우리는 이 행렬을 적절한 크기로 자르려고 하는데, 이때 다음의 규칙에 따라 자르려고 한다.

www.acmicpc.net

문제

N×N크기의 행렬로 표현되는 종이가 있다. 종이의 각 칸에는 -1, 0, 1의 세 값 중 하나가 저장되어 있다. 우리는 이 행렬을 적절한 크기로 자르려고 하는데, 이때 다음의 규칙에 따라 자르려고 한다.

  1. 만약 종이가 모두 같은 수로 되어 있다면 이 종이를 그대로 사용한다.
  2. (1)이 아닌 경우에는 종이를 같은 크기의 9개의 종이로 자르고, 각각의 잘린 종이에 대해서 (1)의 과정을 반복한다.

이와 같이 종이를 잘랐을 때, -1로만 채워진 종이의 개수, 0으로만 채워진 종이의 개수, 1로만 채워진 종이의 개수를 구해내는 프로그램을 작성하시오.

입력

첫째 줄에 N(1 ≤ N ≤ 37, N은 3k 꼴)이 주어진다. 다음 N개의 줄에는 N개의 정수로 행렬이 주어진다.

출력

첫째 줄에 -1로만 채워진 종이의 개수를, 둘째 줄에 0으로만 채워진 종이의 개수를, 셋째 줄에 1로만 채워진 종이의 개수를 출력한다.

예제 입력 1

9

0 0 0 1 1 1 -1 -1 -1

0 0 0 1 1 1 -1 -1 -1

0 0 0 1 1 1 -1 -1 -1

1 1 1 0 0 0 0 0 0

1 1 1 0 0 0 0 0 0

1 1 1 0 0 0 0 0 0

0 1 -1 0 1 -1 0 1 -1

0 -1 1 0 1 -1 0 1 -1

0 1 -1 1 0 -1 0 1 -1

예제 출력 1

10

12

11

 

 

 

 

 

 

 

풀이 .

import java.io.*;
import java.util.StringTokenizer;

public class Main {
    static BufferedReader br = null;
    static BufferedWriter bw = null;
    static StringBuilder sb = null;
    static StringTokenizer st = null;

    static int[][] paper = null;
    static int[] answer = null;
    static int n;

    public static boolean isPossible(int row, int col, int len) {
        int target = paper[row][col];
        for(int i = row; i < row + len; i++) {
            for(int j = col; j < col + len; j++) {
                if(paper[i][j] != target) {
                    return false;
                }
            }
        }
        return true;
    }

    public static void divideAndConquer(int row, int col, int len) {  // row, col은 시작행, 시작열임
        if(isPossible(row, col, len)) {
            int target = paper[row][col];
            answer[target + 1] += 1;  // -1, 0, 1 을 [0], [1], [2]에 담는다.
        }else {
            int nextLen = len / 3;
            for(int i = 0; i < 3; i++) {
                for(int j = 0; j < 3; j++) {
                    divideAndConquer(row + i*nextLen, col + j*nextLen, nextLen);
                }
            }
        }
    }

    public static void main(String[] args) throws IOException {
        br = new BufferedReader(new InputStreamReader(System.in));
        bw = new BufferedWriter(new OutputStreamWriter(System.out));
        sb = new StringBuilder();

        n = Integer.parseInt(br.readLine());
        paper = new int[n+1][n+1];  // 0행, 0열은 버린다.
        answer = new int[3];
        for(int i = 1; i <= n; i++) {
            st = new StringTokenizer(br.readLine());
            for (int j = 1; j <= n; j++) {
                paper[i][j] = Integer.parseInt(st.nextToken());
            }
        }

        divideAndConquer(1, 1, n);
        for(int ans : answer) {
            System.out.println(ans);
        }
    }
}

 

1. 한 장의 종이로 가능한지 검사

2. 불가할 경우 9칸으로 나눠서 재귀

 

인덱스를 맞추는 데 애를 먹다가 파라미터 len으로 해결했다.

굳이 끝나는 인덱스까지 줄 것 없이 몇 칸을 이동할 것인지를 넘겨주면 된다.

+ Recent posts