문제
<그림 1>과 같이 정사각형 모양의 지도가 있다. 1은 집이 있는 곳을, 0은 집이 없는 곳을 나타낸다. 철수는 이 지도를 가지고 연결된 집의 모임인 단지를 정의하고, 단지에 번호를 붙이려 한다. 여기서 연결되었다는 것은 어떤 집이 좌우, 혹은 아래위로 다른 집이 있는 경우를 말한다. 대각선상에 집이 있는 경우는 연결된 것이 아니다. <그림 2>는 <그림 1>을 단지별로 번호를 붙인 것이다. 지도를 입력하여 단지수를 출력하고, 각 단지에 속하는 집의 수를 오름차순으로 정렬하여 출력하는 프로그램을 작성하시오.
입력
첫 번째 줄에는 지도의 크기 N(정사각형이므로 가로와 세로의 크기는 같으며 5≤N≤25)이 입력되고, 그 다음 N줄에는 각각 N개의 자료(0혹은 1)가 입력된다.
출력
첫 번째 줄에는 총 단지수를 출력하시오. 그리고 각 단지내 집의 수를 오름차순으로 정렬하여 한 줄에 하나씩 출력하시오.
예제 입력 1
7
0110100
0110101
1110101
0000111
0100000
0111110
0111000
예제 출력 1
3
7
8
9
풀이 .
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.Collections;
public class Main {
static int[][] map = null;
static boolean[][] check = null;
static ArrayList<Integer> sizeList = null;
static int[] rArr = {-1, 1, 0, 0};
static int[] cArr = {0, 0, -1, 1};
static int n = 0;
static int componentCnt = 0;
static int componentSize = 0;
public static void dfs(int r, int c) {
for(int i = 0; i < 4; i++) {
int nr = r + rArr[i];
int nc = c + cArr[i];
if(0 <= nr && nr < n && 0 <= nc && nc < n &&
map[nr][nc] == 1 && !check[nr][nc]) {
check[nr][nc] = true;
dfs(nr, nc);
}
}
componentSize += 1;
}
public static void main(String[] args) throws IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
n = Integer.parseInt(br.readLine());
map = new int[n][n];
check = new boolean[n][n];
sizeList = new ArrayList<>();
for(int i = 0; i < n; i++) {
char[] ch = br.readLine().toCharArray();
for(int j = 0; j < n; j++) {
map[i][j] = ch[j] - '0';
}
}
for(int i = 0; i < n; i++) {
for(int j = 0; j < n; j++) {
if(map[i][j] == 1 && !check[i][j]) {
check[i][j] = true;
dfs(i, j);
sizeList.add(componentSize); // 각 구성요소마다 사이즈를 기억
componentCnt += 1;
componentSize = 0;
}
}
}
Collections.sort(sizeList);
System.out.println(componentCnt);
for(int size : sizeList) {
System.out.println(size);
}
}
}
DFS 돌리면서 componentSize를 함께 센다.
'알고리즘 문제 > 백준 온라인 저지' 카테고리의 다른 글
[BOJ] 4963 - 섬의 개수 JAVA (0) | 2021.01.19 |
---|---|
[BOJ] 2668 - 숫자고르기 JAVA (0) | 2021.01.19 |
[BOJ] 9466 - 텀 프로젝트 JAVA (0) | 2021.01.19 |
[BOJ] 2331 - 반복수열 JAVA (0) | 2021.01.19 |
[BOJ] 10451 - 순열 사이클 JAVA (0) | 2021.01.19 |