문제
절댓값 힙은 다음과 같은 연산을 지원하는 자료구조이다.
- 배열에 정수 x (x ≠ 0)를 넣는다.
- 배열에서 절댓값이 가장 작은 값을 출력하고, 그 값을 배열에서 제거한다. 절댓값이 가장 작은 값이 여러개일 때는, 가장 작은 수를 출력하고, 그 값을 배열에서 제거한다.
프로그램은 처음에 비어있는 배열에서 시작하게 된다.
입력
첫째 줄에 연산의 개수 N(1≤N≤100,000)이 주어진다. 다음 N개의 줄에는 연산에 대한 정보를 나타내는 정수 x가 주어진다. 만약 x가 0이 아니라면 배열에 x라는 값을 넣는(추가하는) 연산이고, x가 0이라면 배열에서 절댓값이 가장 작은 값을 출력하고 그 값을 배열에서 제거하는 경우이다. 입력되는 정수는 -231보다 크고, 231보다 작다.
출력
입력에서 0이 주어진 회수만큼 답을 출력한다. 만약 배열이 비어 있는 경우인데 절댓값이 가장 작은 값을 출력하라고 한 경우에는 0을 출력하면 된다.
예제 입력 1
18
1
-1
0
0
0
1
1
-1
-1
2
-2
0
0
0
0
0
0
0
예제 출력 1
-1
1
0
-1
-1
1
1
-2
2
0
풀이 .
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Comparator;
import java.util.PriorityQueue;
public class Main {
public static void main(String[] args) throws IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
StringBuilder sb = new StringBuilder();
PriorityQueue<Integer> pq = new PriorityQueue<Integer>((o1, o2) -> {
int abs1 = Math.abs(o1);
int abs2 = Math.abs(o2);
if (abs1 != abs2) {
if (abs1 < abs2) return -1;
else return 1;
} else {
if (o1.intValue() < o2.intValue()) return -1;
else return 1;
}
});
// PriorityQueue<Integer> pq = new PriorityQueue<>(new Comparator<Integer>() {
// @Override
// public int compare(Integer o1, Integer o2) {
// int abs1 = Math.abs(o1);
// int abs2 = Math.abs(o2);
// if(abs1 != abs2) {
// if(abs1 < abs2) return -1;
// else return 1;
// }else {
// if(o1.intValue() < o2.intValue()) return -1;
// else return 1;
// }
// }
// });
int n = Integer.parseInt(br.readLine());
for(int i = 0; i < n; i++) {
int input = Integer.parseInt(br.readLine());
if(input != 0) {
pq.add(input);
}else {
if(pq.isEmpty()) {
sb.append("0\n");
}else {
sb.append(pq.poll() + "\n");
}
}
}
System.out.println(sb.toString());
}
}
우선순위 큐의 정렬 조건을 따로 설정해주면 된다.
new Comparator() 대신 람다식을 사용해서 처리했다.
'알고리즘 문제 > 백준 온라인 저지' 카테고리의 다른 글
[BOJ] 11723 - 집합 JAVA (0) | 2021.03.25 |
---|---|
[BOJ] 19583 - 싸이버개강총회 JAVA (0) | 2021.03.24 |
[BOJ] 15683 - 감시 JAVA (0) | 2021.03.24 |
[BOJ] 2776 - 암기왕 JAVA (0) | 2021.03.23 |
[BOJ] 1269 - 대칭 차집합 JAVA (0) | 2021.03.23 |